PDA

Zobacz pełną wersję : Problem z adresem IP



J.Graph
24-08-08, 22:13
Witam.

Wiem że na forum jest wiele osób które swoją wiedzą mnie zaskakują :)
Tak więc oto mam problem ...

Mam dwie karty sieciowe na płycie głównej, więc podłączam kabel sieciowy do jednej z kart ... ładnie łapie mi adres IP no i śmigam sobie po forum ...
A tu nagle net przestaje działać ... komputer tylko wysyła dane ale nic nie odbiera ...
No to przełączam kabel w drugą karte sieciową ... znowu to samo - łapie IP i net działa przez jakiś z góry nieokreślony czas i znowu staje ...
Mam jeszcze karte sieciową bezprzewodową na USB ...
Wpinam i net smiga - ale po jakimś czasie znowu to samo ...

Teraz najważniejsze ...
Gdy zrobie restart kompa żadna z tych kart nie łapie mi IP z routera ...
mieli, mieli, mieli i wyskakuje albo że połączenie może mieć oraniczenie ,albo łączy sie po jakichś 2 minutach dopiero ALE adres IP zamiast być 10.0.0.3 to jest 169.10..... itd itd .... i internet nie działa ...
Po restarcie routera problem znika na jakiś czas ... potem znowu jest to samo ...

Teraz jeszcze lepsze ...
Oczywiście mowa była o moim stacjonarnym kompie ...
Mam laptopa który stoi przy łózku i cały czas jest wyłączony ...
Gdy internet mi sie "zawiesi" na stacjonarce to jak odpalam laptopa dzieje sie to samo (czyli od razu IP 169.10 ....)

Najlepsze jest to że płyte główną zmieniałem, router zmieniałem ,formatowałem dysk i nadal problem wraca ...

Dziwne bo w domu są jeszcze 2 latopy i jedna stacjonarka i tam ten problem nie występuje NIGDY !!

Może ktoś mnie oświeci bo z tym problemem borykam sie od bardzo długiego czasu a jak narazie nikt mi nie był w stanie pomóc :(

Pozdrawiam.

RadioErewan
24-08-08, 22:23
Nie napisałeś chyba, jaki system, ale i tak stawiam na dostawcę internetu, który ogranicza ilość urządzeń podpiętych jednocześnie do sieci? Może router z opcją niezmniejszania TTL by pomógł?

Pozdrawiam

kranu
24-08-08, 22:27
Tez pomyslalem najpierw o dostawcy internetu ale skoro to jest router to tworzy on druga siec ktora i tak powinna dzialac (przyznany IP itp.) niezaleznie od dostawcy, najwyzej by internet padl. Chyba, ze to switch, a nie router :)

Skoro ten problem nie wystepuje na innych komputerach to moze to kwestia jakiegos oprogramowania ktore masz na stacjonarnym i laptopie? Jakis firewall? Mozna by potestowac tez siec np. jakims Linuxem livecd odpalanym z plyty, czy rowniez by wystapil taki problem.

Mirek54
24-08-08, 22:33
A jak masz w umowie o neta.Jeden komputer,dwa,dziesiec?.Jesli masz tyle podpietych co w umowie to reklamuj jak Ci nie dziala.

Ps Ostatnio czytalem ustawe unijna o ilosci komputerow na m² -mieszkania.Moze przekraczasz?:grin::grin:

J.Graph
24-08-08, 22:40
No więc kończąc ...

System to Win XP ...
Firewall czy inny problem nie dotyczy tego problemu bo nawet na "czysty" XP prosto po formacie ten bug mi wskakuje ...

Dostawca internetowy ??
Miałem Neostrade zamieniłem na Netie ...
I tu i tu to samo ...
Nawet jeśli tylko jeden komp jest włączony dzieje sie to samo ...
Zresztą jeśli by tak było to wcale by mi nie działało ... a czasami jak ten problem zniknie to dopiero po tygodniu wraca ... nie ma na to reguły ...

Bezpośrednio pod router podpięty switch Wifi ...
A dzieje mi sie to i na kablu i na Wifi ...

Ale najbardziej mnie zastanawia co ma wspólnego z moim stacjonarnym mój laptop który leży 2 metry dalej i włączam go tylko do serfowania w necie i oglądaniu filmów pod pierzynką ...

nevra
24-08-08, 22:41
Lucca, a ile może wg niej być? Na maxa i minimalnie? ;)

J.Graph
24-08-08, 22:47
Z tego co mi wiadomo router przez jakiś czas po wyłączeniu komputera pamięta przyznany IP komputera ...
Tak więc po "zwisie" internetu na moim kompie PRAWIE ZAWSZE pomaga wyłączenie i włączenie routera + restart Windozy ...
Ale problem wraca i nie potrafie sie go pozbyć ...

P.S. aha ... ten problem męczył mnie jeszcze zanim Unia zawitała do Polski ;)

RadioErewan
24-08-08, 23:01
No to sprawdź inny router. Jakoś umknęło mi, że komp nie dostaje adresu. Tanie routery lubią poświrować, albo masz coś namotane w serwerze DHCP tego routera (co może sugerować to, że pisałeś o podobnym zjawisku na innym routerze - to ty jesteś wtedy bugiem tego oprogramowania).

Pozdrawiam

J.Graph
24-08-08, 23:09
No to sprawdź inny router. Jakoś umknęło mi, że komp nie dostaje adresu. Tanie routery lubią poświrować, albo masz coś namotane w serwerze DHCP tego routera (co może sugerować to, że pisałeś o podobnym zjawisku na innym routerze - to ty jesteś wtedy bugiem tego oprogramowania).

Pozdrawiam

No to już mój 3-ci router ...
Teraz mam jakiegoś Pentagrama ...

Może routery świrują ... ale przełączałem sie w routerze w inny port i testowałem 3 karty sieciowe u mnie na kompie i żadnych rezultatów ...

płyta główna z wyższej półki więc na nią winy zwalić nie moge, routery zmieniałem ...

Komp dostaje adres IP od routera ...
169.10 itd .... Ale dlaczego skoro każda karty sieciowa ma swój IP ... i powinno być 10.0.0.2 ,10.0.0.3 lub 10.0.0.10 ...

kranu
24-08-08, 23:12
Też myślę, że należałoby sprawdzić inny router, ale inny model i to najlepiej od razu z zintegrowanym wifi.

A może do tego routera poszukać nowszego softu?
Nie ma w nim żadnych logów z których by można by wyciągnąć wnioski?

Co do adresacji IP to jeszcze można przejrzeć czy nie ma żadnych konfliktów typu włączony DHCP i ktoś sobie ręcznie zaadresował komputer.

J.Graph
24-08-08, 23:16
Też myślę, że należałoby sprawdzić inny router, ale inny model i to najlepiej od razu z zintegrowanym wifi.

A może do tego routera poszukać nowszego softu?
Nie ma w nim żadnych logów z których by można by wyciągnąć wnioski?

Co do adresacji IP to jeszcze można przejrzeć czy nie ma żadnych konfliktów typu włączony DHCP i ktoś sobie ręcznie zaadresował komputer.

No właśnie inny router sprawdzałem ... innych firm ... i to samo ...
DHCP na routerze był wyłączony i zawsze taki był i tak zostanie ...
Do routera ma dostęp tylko jedna osoba ... i nic w routerze nie było zmieniane (tylko parametry połączenia z usługodawcą netu) ...
Adresy IP uzyskiwane automatycznie z routera ...

kranu
24-08-08, 23:18
No właśnie inny router sprawdzałem ... innych firm ... i to samo ...
DHCP na routerze był wyłączony i zawsze taki był i tak zostanie ...
Do routera ma dostęp tylko jedna osoba ... i nic w routerze nie było zmieniane (tylko parametry połączenia z usługodawcą netu) ...
Adresy IP uzyskiwane automatycznie z routera ...

Ale tego nie rozumiem :)
"DHCP na routerze był wyłączony i zawsze taki był i tak zostanie "
i
"Adresy IP uzyskiwane automatycznie z routera"

Przecież to sprzeczność bo właśnie DHCP to adresy IP uzyskiwane z routera.

piotrek204
24-08-08, 23:19
Adresy 169.* to adresy ktore przydziela system sam gdy sie nie dogada z dhcp.
Kto jest winny mozna latwo stwierdzic bedac blisko, zdalnie gorzej.
Trzeba poprostu posnifowac co sie dzieje podczas pobierania adresu IP.
Zapros do siebie na piffko jakiegos kumatego w tym czlowieka i on Ci powie kto winien.

P.S. Teraz doczytalem ze masz wylaczony dhcp, powinien byc wlaczony.

J.Graph
24-08-08, 23:28
Adresy 169.* to adresy ktore przydziela system sam gdy sie nie dogada z dhcp.
P.S. Teraz doczytalem ze masz wylaczony dhcp, powinien byc wlaczony.

DHCP mam włączony ...
kranu nie znam sie aż tak dobrze na routerach to mi sie pomyliło ;)
Czyli teraz wiem skąd ten adres 169.

Doszliśmy do miejsca w którym wiadomo że po prostu komp sie nie dogaduje z DHCP ... a co może być tego powodem ...

piotrek204
24-08-08, 23:32
router, konflikty, kable, system, firewalle, wirusy itd.

co moge poradzic na szybko to ustawic na stale adres ip na kompie, powinno pomoc, a pozniej poprosic kogos zeby popatrzyl na problem.

KaarooL
24-08-08, 23:32
Szczerze, to co to za firma Pentagram. Zapoznaj się z ofertą urządzeń Linksys i zapomnisz co to problemy.

Oczywiście możesz konfigurować od nowa, kombinować ale najprościej wyeliminować po kolei ewentualne przyczyny. Nie wiem po co w Twoim kompie dwie sieciówki 10/100/(1000), przecież inny MAC można przypisać programowo.

tasm
24-08-08, 23:40
Hej.
Skoro DHCP swiruje to moze je wylacz i sprawdz czy problem zniknie jesli ustawisz adres statycznie.

Druga sprawa karty sieciowe ktore nie uzywasz poprostu wylacz w panelu strowania nie bedzie podejzenia ze madry windows robi zamieszanie.

RadioErewan
24-08-08, 23:48
Szczerze, to co to za firma Pentagram. Zapoznaj się z ofertą urządzeń Linksys i zapomnisz co to problemy.

Oczywiście możesz konfigurować od nowa, kombinować ale najprościej wyeliminować po kolei ewentualne przyczyny. Nie wiem po co w Twoim kompie dwie sieciówki 10/100/(1000), przecież inny MAC można przypisać programowo.

Kaaarol, opowiadasz. Admin w firmie kupił pięć bramek linksysa i tak jak je lubił, zanim je kupił, tak ich już nie wymawia z namaszczeniem (chyba, że namaszczenie poprzedza splunięcie).

ps. DHCP w routerze włączone. Udostępnianie połączenia internetowego/mostkowanie/co tam jeszcze w innych urządzeniach wyłączone.
Mądry serwer DHCP po napotkaniu w sieci innego sam się wyłącza.

Pozdrawiam

J.Graph
24-08-08, 23:50
Szczerze, to co to za firma Pentagram. Zapoznaj się z ofertą urządzeń Linksys i zapomnisz co to problemy.

Oczywiście możesz konfigurować od nowa, kombinować ale najprościej wyeliminować po kolei ewentualne przyczyny. Nie wiem po co w Twoim kompie dwie sieciówki 10/100/(1000), przecież inny MAC można przypisać programowo.

A Pentagram to Polska firma :-P
Oj taki mam router i już ... mój poprzedni router był właśnie Linksys-a :roll:

W kompie mam dwie karty sieciowe bo tak sobie wymyślił producent płyty głównej w wersji deluxe ...
Karte USB Wifi zawsze mam w pogotowiu gdyby internet na kablu sie obraził ...



Druga sprawa karty sieciowe ktore nie uzywasz poprostu wylacz w panelu strowania nie bedzie podejzenia ze madry windows robi zamieszanie.

Też tak probowałem ...
Karta USB Wifi w szufladzie ... używam sieciówki wbudowanej to ta druga wyłączona ...
Na płycie mam też Firewire i też wyłączałem ...
W ogóle to wszystko możliwe wyłączałem i nic to nie dało ...

RadioErewan
24-08-08, 23:50
Doszliśmy do miejsca w którym wiadomo że po prostu komp sie nie dogaduje z DHCP ... a co może być tego powodem ...

Doszliśmy do miejsca, gdzie wiemy co się dzieje po restarcie kompa. Pisałeś, że sygnał znika wcześniej. Więc problem jest szerszy. Może masz jakieś urządzenie ustawione na sztywno na adres routera? Jak masz trzy laptoki i fyfnaście kart sieciowych... Albo masz dowcipnego sąsiada, który ci się po radyjku whaczył i robi psikusy.

Pozdrawiam

piotrek204
24-08-08, 23:52
Mądry serwer DHCP po napotkaniu w sieci innego sam się wyłącza.


Ten problem mialem jak administrowalem siecia osiedlowa. Chce sie zabic tego co wlaczyl. Ale zeby dhcp sie w tym momencie wylaczyl nie spotkalem, jesli sa dwa to komp dostaje inny adres niz zamierzony ale dostaje, a najczesciej dostaje od tego dhcp do ktorego ma lepsze czasy.
Sa sytuacje gdzie w sieci jest kilka dhcpd i jest to swiadome i wlasciwe.

J.Graph
24-08-08, 23:55
router, konflikty, kable, system, firewalle, wirusy itd.

co moge poradzic na szybko to ustawic na stale adres ip na kompie, powinno pomoc, a pozniej poprosic kogos zeby popatrzyl na problem.

Router - zmieniany 3 razy ...
Konfliktów - chyba brak ...
system - też nie bo od razu po formacie dysku jest to samo ...
firewalli - nie mam ...
wirusy - patrz system ...


A jak ustawić ręcznie adres IP dla komputera ??
Z poziomu windowsa ??
Bo dla przykładu jak karta sieciowa X zawsze dostaje ten sam adres z routera czyli 10.0.0.10 to jak ustawie ją właśnie na 10.0.0.10 to działa połączenie ale netu nie ma ...
No i czy ustawianie ręczne IP nie wpłynie na to że 4 inne kompy łączą sie z routerem przy automatycznym pobieraniu IP ??

RadioErewan
24-08-08, 23:57
OK, są serwery, które napotkawszy pakiety rozgłoszeniowe innego serwera DHCP pracującego na tej samej puli adresowej wyłączają się. Przykładem DHCP z systemów serwerowych Windows. Wielkim magikiem w tej dziedzinie nie jestem, lepiej zapytać Crejzeja.

Pozdrawiam

piotrek204
24-08-08, 23:58
A jak ustawić ręcznie adres IP dla komputera ??
Z poziomu windowsa ??
Bo dla przykładu jak karta sieciowa X zawsze dostaje ten sam adres z routera czyli 10.0.0.10 to jak ustawie ją właśnie na 10.0.0.10 to działa połączenie ale netu nie ma ...
No i czy ustawianie ręczne IP nie wpłynie na to że 4 inne kompy łączą sie z routerem przy automatycznym pobieraniu IP ??

Wlasciwosci karty.
By dzialalo trzeba ustawic adres IP, gateway (brama domyslna), dns.

IP najlepiej inny niz zakres ktory rozdaje router (w konfiguracji sie to podaje), gateway adres routera, dns tez zapewne adres routera.
Dla wszystkich kompow oczywiscie inny IP.

J.Graph
25-08-08, 00:03
Doszliśmy do miejsca, gdzie wiemy co się dzieje po restarcie kompa. Pisałeś, że sygnał znika wcześniej. Więc problem jest szerszy. Może masz jakieś urządzenie ustawione na sztywno na adres routera? Jak masz trzy laptoki i fyfnaście kart sieciowych... Albo masz dowcipnego sąsiada, który ci się po radyjku whaczył i robi psikusy.

Pozdrawiam

Jak mówiłem w routerze zmieniane były tylko współrzędne połaczenia z Netią ... nic więcej ...

wszystkie 5 kompów uzyskuje adres automatycznie ...
na "sztywno" to tylko router jest przytwierdzony do ściany w szafie :wink:

Masz racje że sygnał zanika wcześniej ... czyli to wygląda tak jakby nagle komp przestawał sie dogadywać z routerem ...
Bo jak użyje funkcji "napraw" (która tylko wyłącza, włącza karte sieciową i odświeża IP) to mimo braku restartu wyskakuje IP 169.
_______________________ (automatyczne scalenie)_____________________

router, konflikty, kable, system, firewalle, wirusy itd.


No i właśnie zapomieniliśmy o jednej rzeczy ...
Odpaliłem laptoka ...
U mnie jak narazie net śmiga na Wifi ...
W laptopie nie pobiera IP ...

Dwa oddzielne kopmy, dwa oddzielne systemy - ten sam problem ...
Reszta laptoków i stacjonarnych działa bez problemu ...

rodia
25-08-08, 00:08
J.Graph
Liksysów nie kupuje się bo są lepsze same z siebie. Linksysys kupuje się dlatego bo można wgrać do nich zamiast normalnego firmwaru system linux. - dzięki temu routerek za 150 zł ma funkcjonalność takiego za 500zł.
Oczywiście nie tylko linksysom można wgrać linuxy.

A wracając do twojego problemu. Podobny problem mialem w firmie w ktorej pracowalem kiedys. Zmieniłem router i nic to nie dalo wiec myślalem, ze to nie problem routera. Po dlugich testach kart sieciowych, switchy itd w koncu okazalo się, że to jednak byla wina routera. Ostatecznie pomogło wgranie nowego firmwere'u (ze strony producenta).
Natomiast jeśli chodzi o konfiguracje DHCP to radze tak:
w routerze włącz DHCP, ale przydzielanie niech będzie statyczne: tzn do każdej karty sieciowej ustal sam jaki ma być przydzielany adres IP. Polega to na tym, że dla danego numeru MAC wpisujesz sobie konkretny adres IP.
A TCP/IP dla każdej karty sieciowej ustaw "uzyskaj adres IP automatycznie".
Jeżeli po tym wszystkim będą problemy to już rzeczywiście kup krate czegoś dobrego i zaproś kumpla informatyka.

p.s. Jeszcze jedno, spotkałem się kilka razy z tym, że pewne wirusy tkwiące w komputerach klienckich potrafią powodować zawieszanie routerów (i to nie tylko tych tanich). Na szczęście producenci wypuszczają poprawione firmwary i za każdym razem wgranie najnowszego naprawiało problem. W każdym z tych przypadków użytkownicy ktorym naprawialem siec mieli nigdy nie upradowany firmware - wiec nie dziwo.

p.s.2 Jeszcze jedno mi się przypomniało. Raz spotkałem się z podobnym problemem i okazalo się, że przyczyną było to, że w we własciwosciach karty sieciowej była aktywna opcja "pozwól wyłączać to urządzenie w celu oszczędzania energi". Wyłączenie opcji naprawiło problem.

piotrek204
25-08-08, 00:23
Ile jest kompow w sumie?
Wszystkie maja ten sam problem?
Laczysz je kablem, wifi?

To wyglada na utrate linku, wiec serwer dhcp sam w sobie winny nie jest.
Jak padnie net, nie uzywaj funkcji napraw tylko pusc pinga na adres routera i zobacz czy odpowiada.

Co do linksysa, to w nowych linuksa juz nie wrzucisz.
One nie byly dobre, byly poprostu popularne.
Ja zamiast linksysa kupilem asusa, mam usb. Dzieki temu mam duuuuzo wiecej mozliwosci.
Router robi za serwer drukarek, plikow, www, zrzut obrazu z kamerki i inne :)

J.Graph
25-08-08, 00:29
Dzięki Rodia za dobre rady ... jutro zrobie tak jak radzisz ... zobaczymy co z tego wyjdzie ...
Ale dlaczego problem dotyczy tylko jednego 2 z 5 kompów w tej sieci ??


Co do tematu to coś sprawdziłem ...

Stacjonarka chodzi na Wifi bo żadna z sieciówek nie przyjmuje IP przez kabel ...
Włączyłem laptopa i Wifi nie działa ... podłączyłem do laptopa kabel sieciowy i pobrało IP i internet śmiga ...
Ja już nic nie rozumiem :roll:
_______________________ (automatyczne scalenie)_____________________

Ile jest kompow w sumie?
Wszystkie maja ten sam problem?
Laczysz je kablem, wifi?

To wyglada na utrate linku, wiec serwer dhcp sam w sobie winny nie jest.
Jak padnie net, nie uzywaj funkcji napraw tylko pusc pinga na adres routera i zobacz czy odpowiada.

Co do linksysa, to w nowych linuksa juz nie wrzucisz.
One nie byly dobre, byly poprostu popularne.
Ja zamiast linksysa kupilem asusa, mam usb. Dzieki temu mam duuuuzo wiecej mozliwosci.
Router robi za serwer drukarek, plikow, www, zrzut obrazu z kamerki i inne :)

W sieci jest 5 komow ...
2 stacjonarne i 3 laptopy ...
Ten problem dotyczy tylko mojej stacjonarki i mojego laptopa ...
Reszta nigdy nie miała z tym problemów ...
_______________________ (automatyczne scalenie)_____________________
Zrobiłem mały test ...
Na laptopie udostępniłem dysk ...
Przy prawidłowym uzyskaniu IP jak wiadomo działa ...
Przy IP 169. nie da sie wejść ...
Ten test zrobiłem bo z tego co pamiętam kiedyś to działało bez względu czy komp mi uzyskał IP ...

Dla pewności puściłem ping na adres routera ... i pupa blada ... brak odpowiedzi ...

domadm
25-08-08, 01:38
Kolega miał na jednym z modeli takich małych routerów tak, że jak podpięły się więcej niż 2 kompy na wifi to routerek nie dawał rady (procek zatykał się przy szyfrowaniu WPA2) i padał. Restart oczywiście pomagał... na chwilę.

Czy te komputery które padają (2 z 5) mają po więcej niż 1 interfejsie sieciowym?

J.Graph
25-08-08, 01:39
Czy te komputery które padają (2 z 5) mają po więcej niż 1 interfejsie sieciowym?

Aż takim specem nie jestem i nie za bardzo rozumiem co oznacza ten termin :roll:

Tojfi
25-08-08, 02:06
Z tego co tu wyczytałem to masz Router przewodowy i pezprzewodowy z modemem ADSL.
Cos podobnego do LiveBoxa. Podales za malo danych zeby ci pomóc. Znasz adres IP routera ? Moze spróbuj skonfigurowac recznie ustawienia TCP/IP kompow
NP. Jak router ma adres IP np 192.168.1.1 i chodzi na masce podsieci (zazwyczaj) 255.255.255.0 to w polaczeniach sieciowych kliknij prawym przyciskiem myszy na polaczeniu, które ma polaczenie z routerem i wybierz wlasciwosci. Tam w zakładce ogólne masz protokol internetowy TCP/IP kliknij na nim i pozniej na WLASCIWOSCI. W otwartym oknie zaznacz uzyj nastepujacego adresu IP i po koleji wpisz
(przy zalozeniu ze twoj router ma IP 192.168.1.1) Adrs IP - 192.168.1.2 (jak twoj router ma inny adres to zmien tylko ostatnia cyfre na obojetnie jaka moze to byc cyfra nawet od 2-100) nastepnie maska podsieci - 255.255.255.0 (o ile taka ma router) nastepnie w brama domyslna i serwer DNS wpisz adres ip routera czyli w tym wypadku 192.168.1.1.
Zeby skonfigurowac router otworz przegladarke internetowa i w pasku adresu wpisz IP routera. Jak dodajesz nastepny komputer to robisz to samo, tylko , ze w adresie IP zmieniasz ostatnia cyfrę. Tak, zeby zaden z kompow nie mial tego samego IP. Jak nie wiesz jaki adres IP ma Router to w czasie jak udaje ci sie polaczyc z netem, w menu start wybierz "uruchom" tam wpisz "cmd" (oczywiscie bez " ) w otwartym nowym oknie MSdos wpisz "ipconfig /all" Tam bedziesz mial wyszczegolnione wszystkie karty sieciowe i ich ustawenia, znajdz twoje aktywne polaczenie i z niego mozesz odczytac jaki jest adres ip routera (pole brama domyslna) a nawet mozesz wszystko przepisac i wstawic w te miejsca co opisalem powyzej. Mam nadzieje, ze nie nagmatwalem, bo juz jest troche pozna godzina i szczerze, to z trudem zklaca mi sie zdania :). Jak bys mial problemy to daj znac.

RadioErewan
25-08-08, 02:38
Pytek ma podsieć 10.0.0.x, przynajmniej widziałem gdzieś ten prywatny zakres.

J.Graph
25-08-08, 02:44
Napisałeś to jak totalnemu laikowi ...
A ja już nie raz złożyłem komputer o podstaw ,rozwiązywałem zagadki systemowe, udawało mi sie ruszyć system który padł ...
Do tego moge dodać że wszyscy znajomi walą do mnie jak mają problem z kompem ... czyli jakąś tam wiedze musze posiadać ;)
Ale nie musiałeś tego wiedzieć ... Chciałeś pomóc i to sie liczy i ja to doceniam ... Ale musiałem napisać sprostowanie żeby nie wyszło że noobem jestem :cool:

Co do tego co napisałeś to jest tylko jeden mały problem ...
Każda karta sieciowa ma swoj indywidualny adres IP i zawsze dostaje ten sam przy połączeniu z routerem ...
Mógłbym zmienić adres IP ręcznie we właściwościach kart sieciowej tylko ...
Bo zrobiłem to włąśnie na laptopie i jak widać powiodło sie bo pisze tutaj ;)
Może to by rozwiązało problem ... Bo wcześniej tego próbowałem ale nie działało z jednego powodu ... nie wpisywałem adresu serwera DNS ...
A ten problem to skąd mam wiedzieć jaki adres karty wpisać skoro karta za Chiny ludowe nie chce mi pobrać swojego IP z routera ?? :cry:

No i jeszcze jedno ... Czy jeśli karta sieciowa pobiera za każdym razem adres np. 10.0.0.2 czy da sie ten adres zmienić jakoś ?? no bo dlaczego jedna karta ma 10.0.0.3 a inna 10.0.0.71 ?? skąd sie bierze tak wielki odstęp pomiędzy adresami ??

RadioErewan
25-08-08, 03:26
Serwer DHCP losuje sobie jakiś adres z zakresu jaki ma zdefiniowany.
Klasa C to zazwyczaj definiowany zakres działania małego serwera. W takim wypadku do dyspozycji masz 254 numerki. Taka klasa definiowana jest maską podsieci 255.255.255.0 i tak masz pewnie zdefiniowane parametry w routerze.
Dostajesz ciągle ten sam numer, bo nie wygasa dzierżawa adresu. Często czas dzierżawy adresu wynosi 7 dni. Tak więc jak w ciągu 7 dni dwa razy zapytasz o adres dla twojej karty sieciowej, dwa razy dostaniesz ten sam IP. Jeżeli czas pomiędzy dwoma zapytaniami wyniesie więcej jak czas dzierżawy, serwer ponownie wylosuje sobie jeden z 254 numerów IP.
Powinieneś dla każdej karty sieciowej dostawać innego IPka.

Pozdrawiam
_______________________ (automatyczne scalenie)_____________________
Dodam jeszcze, że wydaje mi się, iż masz jakieś skuchy w konfiguracji routera. W DHCP powinieneś dostać adres DNS. Sprawdź sobie jaki adres DNS dostają te komputery, które działają sprawnie. W XP dowiesz się tego wywołując konsolę (Menu start|Uruchom|cmd[Enter]) i wpisując w niej "ipconfig /all".

Pozdrawiam

J.Graph
25-08-08, 04:16
Dodam jeszcze, że wydaje mi się, iż masz jakieś skuchy w konfiguracji routera. W DHCP powinieneś dostać adres DNS. Sprawdź sobie jaki adres DNS dostają te komputery, które działają sprawnie. W XP dowiesz się tego wywołując konsolę (Menu start|Uruchom|cmd[Enter]) i wpisując w niej "ipconfig /all".

Pozdrawiam

No więc zdaje relacje z placu boju ...
Przymierzałem sie do formatu dysku od jakiegoś czasu ...
Mój stacjonarny ma nowego i lśniącego windowsa ...
Czyli jak to bywa po formacie ,mjut ...

No i najciekawsze ... obydwa kompy były wyłączone ...
poszedłem zresetować router ... potem wróciłem do pokoju i sytuacja sie nie zmieniła ... :shock:

Na moim stacjonarnym nadal nie działa net na kablu ani na jednej ani na drugiej sieciówce ,lecz gdy ten kabel podłącze do latopa działa bez problemu ...
Wbudowana karta sieciowa Wifi laptopa nie zbiera adresu IP a gdy podłącze moją karte Wifi do stacjonarki działa ...
W tym momencie zgłupiałem ...
Router resetowałem ze 3 razy ... nadal to samo ... za chwile coś mnie trafi :evil:

Radio odpowiadając na Twoje pytanie:
DNS dostaje 10.0.0.2 czyli taki sam jak adres routera ...
Wpisałbym ręcznie IP danej karty sieciowej ale jeśli nie wiem jaki ona ma teraz IP to nic nie zrobie ...
U mnie nigdy sie nie zdarzyło żeby przez 7 dni nie włączać kompa tak więc jak mi raz złapie IP to sobie poradze ... tylko jak to wymusić w takiej sytuacji :roll:

P.S. Acha ... i co do dzierżawy w linii komend wyświetla mi że wygasa za 24h ... to jakaś pomyłka bo nawet po 48h moje IP sie nie zmieniło ...
_______________________ (automatyczne scalenie)_____________________
Kolejna nowinka ...
Po nieudanym pobraniu adresu IP przez karte sprawa wygląda następująco :
Zamiast IP 10.0.0.7 jest 169.254.133.36
Zamiast maski podsieci 255.255.255.0 jest 255.255.0.0

Pole Bramy domyślnej i DNS świeci pustkami ...
_______________________ (automatyczne scalenie)_____________________

Zapoznaj się z ofertą urządzeń Linksys i zapomnisz co to problemy.

Co do twojego super routera ;)


Na google wpisałem owy problem to tam wyskoczyla masa stron i oczywscie jako główny powód problemu był napisany moj ruter Linksys WAG200G

W necie szukałem nadal rozwiązania mojego problemu i z tego co widze ludzie tylko narzekają na firme Linksys :roll:

NightCrawler
25-08-08, 07:49
Ze zapytam bo juz sie zgubilem po drodze...
mozesz wejsc w panel administracyjny routera?
Jezeli tak to moze przypisz w opcjach routera ip dla kazdego z urzadzen (po mac;u) na sztywno i zobacz jak wtedy to bedzie chodzilo.
W takiej sytuacji router zawsze bedzie dla danego mac'a ustawial odgorne ip.

A co do linksysa - to zalezy co sie kupi... sa wynalazki ktorych nie warto, a sa modele ktore smigaja bez najmnijeszych problemow, a po zmianie firmware uzyskuje sie dostep do funkcji o jakich mozna pomarzyc normalnie w routerach z tego przedzialu cenowego... (aczkolwiek ta mozliwosc nie tylko linksys daje :) )

Jacunio
25-08-08, 08:14
Zrób inaczej: po prostu wyłacz jeden z dwóch interfejsów w kompie. Na aktywnym ustaw na sztywno IP, maskę, bramę i DNSy. Na 100% będzie działać.
Mój brat miał identyczny problem, nie udało mi się ustalić co się dzieje - wszystkie ustawienia i konfigurację miał prawidłowe.

marcinpolniak
25-08-08, 08:22
Jak wyłączysz DHCP i przypiszesz ręcznie numery IP to dalej są problemy?

kasprzyk
25-08-08, 08:25
Co do tego co napisałeś to jest tylko jeden mały problem ...
Każda karta sieciowa ma swoj indywidualny adres IP i zawsze dostaje ten sam przy połączeniu z routerem ...



Każda karta ma indywidualny fizyczny adres MAC, nie IP, IP nadaje router czy dostawca po zidentyfikowaniu MAC-a karty.
Tak więc możesz zmienić MAC karty w stacjonarnym na dowolny (inny niż pozostałe karty w Twojej sieci)

Po każdorazowym zmianie karty sieciowej (czy jej MAC-a) musisz zrestartować Router - on pamięta stare ustawienia - ale pewnie to wszystko co teraz pisze jest Ci wiadome ;) - to tylko tak dla formalności.

Skoro nie działa DHCP, to wyłącz tą opcję i przypisz każdemu komputerowi ręczne ustawienia.

Sorry, jeżeli teraz pisze nie na temat - bo niestety nie przeczytałem wszystkich postów w tym wątku.

Kiedyś mieliśmy taki komputer z którym walczyliśmy chyba tydzień, formatowania, podstawiona karta, inne systemy operacyjne - okazało się, że była przetaktowana płyta główna - po przywróceniu biosu do normalnych parametrów zaczęło działać - ale ty płytę już podstawiałeś ?
Pzdr

marcinpolniak
25-08-08, 08:32
Może jednak sprawdź jakie masz adresy MAC kart sieciowych, u mnie na uczelni zdażyło się tak, że dwie karty miały identyczny adres :-)

KaarooL
25-08-08, 08:45
Nie licytuj się chłopie na urządzenia bo nie o to tu chodzi. Na chacie mam Linksys'a, postawiłem raz i zapomniałem, paru kumatych kumpli też ma osprzęt tej firmy i nikt nie płacze.

Na Twoim miejscu bujnąłbym tego problematycznego kompa z Knoppix'a i sprawdził czy dostanie IP i czy będzie je potem gubił.

piotrek204
25-08-08, 11:03
Z opisu wynika ze problem nie dhcp a samego linku do routera, jesli raz pobierze a pozniej net pada to oznacza ze link padl. Pozniej nie pobiera adresu bo nie ma linku.
Prolemy z samym linkiem wi-fi to czesta sprawa, moze router nie wyrabiac, moze byc inna siec na tym kanale w poblizu itd.

qbic
25-08-08, 11:18
co bym wykonał po kolei:

- wyłącz oszczędzanie energii dla kart sieciowych

- ustaw link na 10mbps (dla sieciowki w komputerze), jak zadziała to znaczy ze masz uszkodzony kabel, w tanich sprzętach spieprzona jest auto-negocjacja szybkości łącza.

- zobacz jak Ci się uda wejść w panel routera czy masz filtr na MAC adresy, wygląda na to ze niektóre MACe dostają adres a niektóre nie

- zrób reset routera do ustawień fabrycznych (mam nadzieje ze wiesz jakby co z którego portu klonować adres MAC dla routera?)

- nie kupować tanich routerów, a jak już tani to WRT54GL

Tojfi
25-08-08, 12:14
Jak nie chcesz bawić sie w konfiguracje routera, to ustaw na sztywno IP w kazdym kompie, jak router twój ma 10.0.0.2 to w pozostalych kompach mozesz ustawic IP z tego samego zakresu czyli 10.0.0.5, 10.0.0.10, 10.0.0.15 itd. Jako brame domyslna i serwer dns wpisz ip routera czyli 10.0.0.2, jako zapasowy DNS mozesz wpisac chociażby dns tepsy - 194.204.159.1 .Nie musisz wyłączać DHCP w routerze, jak komputery beda mialy przypisane na sztywno IP to i tak nie beda pobierac go z DHCP routera. To powinno pomóc i od tego bym zaczął.

Koriolan
25-08-08, 14:23
Miałem kiedyś takie jazdy.. winny był switch pomiędzy routerem a kompem.

Po kolei, wątek już długi
a) Dostawca to Netia. Autoryzacja po MACu urządzenia (po stronie Netii) odpada-chyba nie stosują..
b) masz modem-router i do tego podpięty AP ?-czyli dwa urządzenia.

c) do urządzenia podłaczone są: 3 laptopy po WIFi i 2 stacjonarne.
Problem występuje dla jednego z laptopów i jednego stacjonarnego?

True?

Teraz pytania.
Jaki jest adres modemo routera a jaki AP czyli switcha wi-fi po stonie LANu ( zdaje się stosujesz adresy klasy 10.0.0.x ?

Napisałeś, ze adresy poszcególnym komputerom nadałeś ręcznie. Czy którys z adresów komputera nie pokrywa się z adresami switcha AP /routera?

Osobiście na tym etapie postawiłbym wszystko "od zera" najprościej jak można.

Adres routera: 10.0.0.1
Adres AP (Access pointa) - 10.0.0.100. (na sztywno)
Na routerze uruchomił był DHCP podając pulę adresów od 10.0.0.2 do 10.0.0.20
Wszystkim komputerom kazałbym przyjac adresy z DHCP.
Rady z cyklu głupich

a) wyłącz Fire Wire na kompie
b) wyłącz jedną z kart sieciowych w BIOSie


Moze pomoże..

Pozdrawiam

qbic
25-08-08, 14:34
a) wyłącz Fire Wire na kompie


To może jeszcze laleczka voodoo i modlitwa?

RadioErewan
25-08-08, 14:35
A tak swoją drogą, adres routera 10.0.0.2 wygląda dziwacznie.

Pozdrawiam

Koriolan
25-08-08, 14:39
Jeżeli dobrze doczytałem wszystkie informacje- to obstawiam konflikt
właśnie pomiędzy adresami komputerów a modemu i AP.
ale może nie mam racji.
_______________________ (automatyczne scalenie)_____________________


To może jeszcze laleczka voodoo i modlitwa?


Niestety usuwanie takich problemów to jest trochę voodoo. a czasem WuDa

coolgago
25-08-08, 19:18
Najlepiej byłoby gdybyś wstawił na forum kilka screen-ów (fotki - zrzut ekranu) ustawień adresów kart sieciowych i ustawień routera.
Screen łatwo zrobić wciskając klawisz Print Screen i wklejając zawartość schowka do dowolnego edytora grafiki.
Opisując problem mogłeś coś nieświadomie pominąć, coś co inni będą w stanie zauważyć.

J.Graph
26-08-08, 15:43
To może jeszcze laleczka voodoo i modlitwa?


Chyba pomogło ;)

Tak jak juz wcześniej pisałem robiłem format dysku ... po formacie nadal było to samo ... wkurzyłem sie ,powyłączałem kompy i poszedłem spać ...
Rano chciałem coś z routerem pokombinować ... więc włączam kompa i internet działa :shock:
Komp dogadał sie z routerem ... mam adres IP ...
Długo nie myśląc zablokowałem ten IP czyli wpisałem go ręcznie w połączeniu ...
Jak narazie wszystko działa (chyba troszke net przez to muli - albo mi sie zdaje) i zobaczymy jak długo ... używam neta, ściagam, przesyłam ... robie wszystko żeby znowu sie zawiesił ... ale jak narazie nie chce ...
Mam nadzieje że manualne wpisanie adresu IP wyeliminuje problem ...
Jak sie znowu popsuje będziecie pierwszymi któzy sie dowiedzą :)

Kończąc tę wiadomość, chciałem wszystkim bardzo serdecznie podziękować ...
Dużo mi wyjaśniliście, dowiedziałem sie kilku szczegółów które pozwoliły mi inaczej popatrzeć na ten problem ...
Z ręka na sercu moge powiedzieć że adres IP mam dzięki wam :)

A teraz pytanie dla osoby która wie : Ile moge rozdać punktów reputacji ??
Bo mimo ze punkty to nic specjalnego to jednak chciałbym sie jakoś odwdzięczyć za zainteresowanie tematem ...

Pozdrawiam

qbic
26-08-08, 16:24
Długo nie myśląc zablokowałem ten IP czyli wpisałem go ręcznie w połączeniu ...
Jak narazie wszystko działa (chyba troszke net przez to muli - albo mi sie zdaje)

Zdaje Ci się. Nigdy nie słyszałem żeby wpisanie adresu IP na sztywno wpływało na jakość połączeń TCP.

Jacunio
26-08-08, 16:33
Stały adres IP na pewno nie, ale wtedy trzeba także ustawić poprawne adresy serwerów DNS i to już może mieć wpływ na szybkość translacji adresów i łączenia sie.

qbic
26-08-08, 16:41
Stały adres IP na pewno nie, ale wtedy trzeba także ustawić poprawne adresy serwerów DNS i to już może mieć wpływ na szybkość translacji adresów i łączenia sie.


Translacji adresów....? chyba chodziło Ci o rozwiązywanie nazw.

Tojfi
27-08-08, 09:41
Chyba pomogło ;)

Długo nie myśląc zablokowałem ten IP czyli wpisałem go ręcznie w połączeniu ...
Jak narazie wszystko działa (chyba troszke net przez to muli - albo mi sie zdaje) i zobaczymy jak długo ... używam neta, ściagam, przesyłam ... robie wszystko żeby znowu sie zawiesił ... ale jak narazie nie chce ...
Mam nadzieje że manualne wpisanie adresu IP wyeliminuje problem ...
Jak sie znowu popsuje będziecie pierwszymi któzy sie dowiedzą :)


Pamietaj tylko, żeby ustawic recznie adresy IP na pozostałych kompach, bo może ci sie zdarzyć ,że serwer DHCP rotera przypisze innemu kompowi adres IP, który innemu nadales na sztywno i bedziesz mial konflikt adresów.

Nie ma mozliwosci, żeby ręczne wpisanie konfiguracji TCP/IP zamulało ci kompa, tak ze napewno ci sie zdaje :)

Pozdrawiam

PS. też mam w domu 4 kompy podpięte przez WiFi, oprocz tego 2 bramki Voip podpięte kablem i czasami przynosze jeszcze laptopa z roboty, albo wpada do mnie brat ze swoja nokia która też ma WiFi. Wszystko mam ustawione na sztywno (mam przekierowane potrzebne porty UDP i TCP do swojego kompa i tak było najprosciej) ,wszystko smiga bez zarzutu mimo że to LiveBox, który czasami naprawde potrafi wkurzyc ;).